Browse Source

Fix build when enabling presto+ftd2xx driver only.

git-svn-id: svn://svn.berlios.de/openocd/trunk@1593 b42882b7-edfa-0310-969c-e2dbd0fdcd60
tags/v0.2.0
zwelch 13 years ago
parent
commit
caf14c53db
1 changed files with 4 additions and 4 deletions
  1. +4
    -4
      configure.in

+ 4
- 4
configure.in View File

@@ -537,7 +537,7 @@ then
AC_MSG_ERROR([The option: with_ftd2xx_linux_tardir is for LINUX only.])
fi

if test $build_ft2232_ftd2xx = yes ; then
if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
AC_MSG_CHECKING([for ftd2xx.lib exists (win32)])

# if we are given a zipdir...
@@ -586,7 +586,7 @@ then
AC_MSG_ERROR([The option: with_ftd2xx_linux_tardir is for LINUX only.])
fi

if test $build_ft2232_ftd2xx = yes ; then
if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
AC_MSG_CHECKING([for libftd2xx.a (darwin)])

if test ! -f /usr/local/include/ftd2xx.h ; then
@@ -607,7 +607,7 @@ then
AC_MSG_ERROR([The option: --with-ftd2xx-win32-zipdir is for win32 only])
fi

if test $build_ft2232_ftd2xx = yes ; then
if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
# Must be linux
if test $host_os != linux-gnu && test $host_os != linux ; then
AC_MSG_ERROR([The (linux) ftd2xx library from FTDICHIP.com is linux only. Try --enable-ft2232-libftdi instead])
@@ -661,7 +661,7 @@ if test $build_ft2232_ftd2xx = yes ; then
fi
fi

if test $build_ft2232_ftd2xx = yes; then
if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes; then

# Before we go any further - make sure we can *BUILD* and *RUN*
# a simple app with the "ftd2xx.lib" file - in what ever form we where given


Loading…
Cancel
Save