Browse Source

jimtcl: update to 0.77, the current version, enable only specific modules

This is needed to fix build on aarch64 to get updated config.guess.

Because some newer JimTcl modules that get enabled are failing to
build on some of the platforms OpenOCD supports, enable only a
fixed set that shouldn't cause any issues.

We also disable running Jim Tcl tests on distcheck because they never
worked (before 85358e479e Jim commit)
but didn't break Jenkins build; with newer version they're getting run
and fail due to limited permissions for filesystem and networking
operations.

Change-Id: I0b6c6a00bf2cf0902bbb01c9c0224fe93c74ac94
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Reviewed-on: http://openocd.zylin.com/3700
Tested-by: jenkins
Reviewed-by: Andreas Fritiofson <andreas.fritiofson@gmail.com>
tags/v0.10.0-rc1
Paul Fertser 3 years ago
parent
commit
56d163ce79
3 changed files with 6 additions and 2 deletions
  1. +4
    -0
      Makefile.am
  2. +1
    -1
      configure.ac
  3. +1
    -1
      jimtcl

+ 4
- 0
Makefile.am View File

@@ -5,6 +5,10 @@ AUTOMAKE_OPTIONS = gnu 1.6
# make sure we pass the correct jimtcl flags to distcheck
DISTCHECK_CONFIGURE_FLAGS = --disable-install-jim

# do not run Jim Tcl tests (esp. during distcheck)
check-recursive:
@true

nobase_dist_pkgdata_DATA = \
contrib/libdcc/dcc_stdio.c \
contrib/libdcc/dcc_stdio.h \


+ 1
- 1
configure.ac View File

@@ -550,7 +550,7 @@ AS_IF([test "x$build_buspirate" = "xyes"], [

AS_IF([test "x$use_internal_jimtcl" = "xyes"], [
AS_IF([test -f "$srcdir/jimtcl/configure.ac"], [
AX_CONFIG_SUBDIR_OPTION([jimtcl], [--disable-install-jim])
AX_CONFIG_SUBDIR_OPTION([jimtcl], [--disable-install-jim --with-ext="eventloop array clock regexp stdlib tclcompat" --without-ext="default"])
], [
AC_MSG_ERROR([jimtcl not found, run git submodule init and git submodule update.])
])


+ 1
- 1
jimtcl

@@ -1 +1 @@
Subproject commit 51f65c6d38fbf86e1f0b036ad336761fd2ab7fa0
Subproject commit a9bf5975fd0f89974d689a2d9ebd0873c8d64787

Loading…
Cancel
Save